Can't seem to enable servos using ROS

On the plus side: fitted a PI3 and camera to Marty used your latest raspberry PI image can connect to the marty wifi

Started to follow the"Advanced Marty Raspberry PI Camera and ball following"

everything appeared to work, I could connect to the Marty hotspot and VNC into the PI, see battery voltage, camera output, calibrate the camera to detect a ball.

I typed in the python code under the heading "Actually do something" and Marty did not move.

The confusing thing is that the command roslaunch ros_marty calibration.launch works, I can calibrate marty.

So tonight I worked through the Deep-Dive with ROS instructions.

<hr>

Following is not a problem with enabling the servos, just a comment on the instructions.

Under the section "Actual ROSing around" when I entered devmux into the terminal I got an error message saying rostopic could not be found until I entered bash. Is that because I did not follow export ROS_MASTER_URI=http://192.168.0.12:11311 source /opt/ros/kinetic/setup.bash

on my PI?

<hr>

When I enter rostopic pub /marty/enable_motors std_msgs/Bool "data: true"

I get an error message [WARN} [WallTime: ….] Inbound TCP/IP connection failed: field data is not a bool I have tried using 'true' True 'True' and get the same response

I have pressed ctrl-c and then entered rostopic pub /marty/keyframe_file std_msgs/String "data: 'wave'" nothing happens.

I have just noticed a space between data: and true, could this be my problem?

Discussion

Leave a comment and join the discussion here


Please Log In or Sign Up to write a comment response

1 Responses

Windy54 OP

It is typical as soon as I post a query I manage to fix it.

I used the auto-completion to enter the command to enable the servos and then edited the line to change false to true.

Marty then waved! I also used the test servo_test.py script and marty's eyes and left hand moved.

Still can't get him to walk, but at least I am know I am enabling the servos!

20:14:03, 28th February 2018   |   Permalink   |   View Source