Marty Android & iOS App Beta - Feedback and Discussion

As mentioned on the blog, we've released a Beta Android app (iOS App coming soon) that makes calibration and WiFi setup a lot easier, and will replace the way of doing things as written in the Setup & Calibration Guide.

We're keen to get feedback from those of you already using Marty and those of you us a comment beused to our original setup system. The app is pretty different in its approach, but we're hoping it'll remove some of the headaches from the process. Leave low with any thoughts, suggestions or glitches!

The app can also be used in lieu of the scanning tool on the Docs site, too, as a quicker alternative.

UPDATE

Both the Apple and Android apps are now publicly available on their respective app stores.

Download the app from the Play Store: Google Play Store link

Download the app from the Apple App store: App Store Link

Discussion

Leave a comment and join the discussion here


Please Log In or Sign Up to write a comment response

16 Responses

sandy STAFF

Hi all,

We've just pushed an update to the Android app into beta. It's mainly based around a couple of bug fixes and guiding people through the wifi setup process a bit more, since that's where most of our support queries come from. We're planning on pushing out a few more updates in fairly quick succession, and we'll be looking pretty soon at getting the remote control tidied up.

Anybody who's subscribed to the Android Beta should be able to get the updated version now, and if you have any other suggestions for updates and features please just let us know

Sandy

18:50:59, 02nd April 2018   |   Permalink   |   View Source
rayfarmer

Actually the Get Ready button - sometimes it needs to be pressed a couple of goes to completely get Marty standing correctly.

Also the Controller screen seems to be a bit keen to bring the Copy|Select All|Select option which is a bit annoying.

20:33:19, 21st March 2018   |   Permalink   |   View Source
rayfarmer

Thanks, I found the button. There is a bit of an issue with the Controller screen. Sometime I am unable to scroll the screen. After doing the Calibrate, I entered the Controller screen from the Calibration. I found that I couldn't scroll the screen. I also found that the joystick control didn't do anything. I closed the app and reopened it then when straight to the Controller. This time I was able to scroll the screen. The joy stick control also worked. I thought this locking or freezing of the screen only occurred from the coming from the Calibration. But I have also had locking or freezing of the screen from selecting the Controller option. It seemed to occur the first time entering the Controller screen. If I close the app and reopen it and then select Controller, I was able to scroll the screen and the Get Ready appears to operate correctly.

20:28:09, 21st March 2018   |   Permalink   |   View Source
angus OP STAFF

@rayfarmer you might need to scroll, depending on the screen size! It's at the bottom below the 'Back' button

15:49:03, 21st March 2018   |   Permalink   |   View Source
rayfarmer

Actually no, as I didn't spot a Get Ready button. Is it one of the buttons above the Forward/Back/Left/Right buttons?

13:26:11, 21st March 2018   |   Permalink   |   View Source
angus OP STAFF

@rayfarmer did you try the "Get Ready" button? It's a sort of reset for the motors, which will be disabled by the control board if they have to push against something too hard.

13:00:39, 21st March 2018   |   Permalink   |   View Source
rayfarmer

I tried the IOS app, the calibration seemed fine and no problem find my Marty but when using the Marty Controller and using the Left and Right buttons, My Marty ended up with legs splayed out and I couldn't get him to stand up straight again!

12:52:46, 21st March 2018   |   Permalink   |   View Source
angus OP STAFF
20:00:01, 19th March 2018   |   Permalink   |   View Source
heybuddy

Awesome! Thanks!

20:56:39, 18th March 2018   |   Permalink   |   View Source
angus OP STAFF

@heybuddy we have a Test flight Beta of the iOS app we could add you to, just sent support your iCloud email and we'll add you

20:18:07, 18th March 2018   |   Permalink   |   View Source
heybuddy

The app sounds great! I'm excited to try out the ios version when it becomes available!

20:13:49, 18th March 2018   |   Permalink   |   View Source
[deleted]

[deleted]

05:25:00, 09th January 2018  *   |   Permalink   |   View Source
Klauscon

Installed it on a Samsung Galaxy S5 neo. When first detecting Marty on the MartySetup Wifi it got till the resetting network part, then froze. I manually rebooted marty and it connected to the new WIFI. Scanned for it with app and found it , but the calibration seems a little off for the eyes. Saved the calibration but not sure it actually took, as I had to move slider same amount each time. Controlling marty worked, although initially the legs didn't walk properly, and the right arm failed to react. Tried it with Scratch and worked ok from there. Went back to app, and all controls worked.

10:47:47, 01st December 2017   |   Permalink   |   View Source
ddoak

Phone (Android 6.0) didn't have WebView installed - so installed it from Play Store. Tablet (Android 5.1) had WebView installed (according to Play Store and was up to date) Chrome installed and up to date on both.

Hasn't changed anything - both can still detect but not control (have also rebooted both devices).

On a brighter note - I also just tried a Samsung Galaxy Tab S. Initially had the same issue but worked after installing WebView.

13:34:25, 19th November 2017   |   Permalink   |   View Source
sandy STAFF

Hi there,

Thanks for the feedback - it's really useful!

I suspect this is because the scanning and the controlling use different methods. The control and calibrate functions use a websocket, and it sounds like that's not working properly on your devices

I did find a similar issue with a tablet I tried it on, which I think was solved by updating Chrome and Android WebView. Any chance you could give that a go?

In the mean time I will look into using a different method for connecting to Martys!

Sandy

11:57:38, 19th November 2017   |   Permalink   |   View Source
ddoak

Just tried it on both my android phone (Oukitel K6000) and tablet (Chuwi HI12)*

On both devices the app detects Marty's on the local wifi (scan for marty) and correctly picks up their IP addresses and names - but then doesn't seem to be able to communicate with them any further than that (i.e. control, calibrate and clear calibration do nothing).

*although cheap and cheerful, both devices are generally happy running most apps

15:53:14, 17th November 2017   |   Permalink   |   View Source