What next? Installed ROS on my pi

Hi,

Looking for some more help. sorry... I have now installed ROS on the Pi and its connected to the network. I'm sure im missing something however in relation to Marty.

I have since found: https://robotical.io/learn/article/Deep-Dive%20with%20ROS/Practice/

Things you'll need

I have cloned the two packages into ROS (src directory) but not sure where to go from here...

Any help would be great!!!!

Martin

Discussion

Leave a comment and join the discussion here


Please Log In or Sign Up to write a comment response

3 Responses

sandy STAFF

Hi there!

Sorry for the slow reply, lots of plates spinning at the moment!

Getting ROS + openCV + our packages installed from Scratch really does take a while! Then there are some complications with using serial on the Raspberry Pi 3 which need to be tweaked too... It's much easier if you have a spare microSD card to download our Raspberry Pi image which already has all that stuff on it!

I think we need to put together a more specific set of instructions (or maybe just a script!) for installing it all from Scratch - but for now if you could use the image that would be much easier! ;-)

I've also just made a forum post that details how to get started with the pi image - just skip over the camera-ey bits if they're not useful to you!

All the best,

Sandy

11:39:08, 24th October 2017  *   |   Permalink   |   View Source
thebeetleuk OP

After more investigation I think I have a problem with dependancies. The tf2_ros ins't present and looking at it on github I feel like I'll be going down a long path of getting all those installed. Please help :)

15:09:31, 06th October 2017   |   Permalink   |   View Source
thebeetleuk OP

I'm now a bit further on but still have issues...

So I have cloned the two packages into the src directory and tried to

Resolved dependencies: rosdep install --from-paths src --ignore-src --rosdistro indigo -y -r --os=debian:jessie

This threw and error:

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: ros_comm: No definition of [roslisp] for OS [debian] ros_marty: Cannot locate rosdep definition for [marty_description]

then i tried

catkin_make

and this threw the error below when it got processed ros_marty. I gues I'm not installing properly??

-- +++ processing catkin package: 'ros_marty' -- ==> add_subdirectory(ros_marty) CMake Warning at /home/pi/ros_catkin_ws/devel/share/catkin/cmake/catkinConfig.cmake:76 (find_package): Could not find a package configuration file provided by "tf2_ros" with any of the following names:

tf2_rosConfig.cmake tf2_ros-config.cmake

14:00:06, 06th October 2017   |   Permalink   |   View Source