Problems with Raspberry Pi

This post is mainly to see if others are seeing similr problems - I'm going to be testing more to try to fix the problems below. I'm very familiar with Linux, use the Pi a lot and am programming stm32f4 devices as part of my work, so

I've started with the image at: https://cdn.robotical.io/public/raspberry-pi-img/robotical-pi.17.07.img.gz

I tried this with an older Pi with fill size SD, but it wouldn't fit in Marty - the micro SD ones is fine. For this reason I've not tried the oldest Pi versions, but I probably will later.

I then tried a Pi B 1.2, and this failed to boot (a kernel panic displayed when attached to a screen. I tried a second, better micro SD, and this also didn't boot. I've borrowed a Pi 3 and that boots fine, so it seems the image is only for Pi 3.

However there are a few more problems.

The image doesn't recognise the wifi, but it's running as an access point, so presumably hostapd has it in use. I'll have a bit of time to check this in the week; I've used hostapd quite often so I don't expect that to be too hard to fix. I'm using standard ethernet to debug. so for now the Pi is mounted externally with the link cable through the mouth.

The next problem is Marty not always being found; roslaunch ros_marty startup.launch seems to only work part of the time. I'm running plugged in, so power should be ok (but see below), and I'm investigating further.

Another more problematic issue is occasional episodes of marty throwing a fit - fast random motor movements until turned off (I don't wait for long to avoid damage). This only happens with the Pi attached, and while trying to set up wifi while connected via ssh over ethernet. I did wonder if the problem might be if the 5v gets drained a bit too much, as I know the ethernet connection does cause a surge in power usage when it starts up. I'll try to monitor the 5v line - I've got an stm32f4 board I've programmed that I can use to do that. Low voltage could also possibly explain unexpected movement.

Mike

Discussion

Leave a comment and join the discussion here


Please Log In or Sign Up to write a comment response

6 Responses

mikeprotts OP

I've not been able to do more on this for a while - I'm possibly picking it back up next week. I was trying to get a camera to work first, but eventually worked out that the camera I had was faulty (I borrowed on that did work) and spend far too much time on that.

I'll have a go with the October build and see how far I get as I am keen to do this as well. I've got a wifi dongle that I've used before so I hope it will not be too tricky.

Mike

20:33:17, 19th February 2018   |   Permalink   |   View Source
Mark

Mike, did you manage to get Wifi working with the Rpi? I have followed Sandy's suggestion below and added a Wifi dongle. Unfortunatley using the latest Robotical image (Oct 2017) I am unable to get the Wifi working.

Whilst connected via ethernet I can SSH & VNC into the Rpi, wpa_supplicant.conf has been updated with the correct wifi details. When unplugging the ethernet I am unable to ping the Rpi.

Any advice and guidance is most appreciated.

Thank you.

Mark

11:54:55, 19th February 2018   |   Permalink   |   View Source
thebeetleuk

Thanks Mike!

21:46:49, 23rd September 2017   |   Permalink   |   View Source
mikeprotts OP

I've not got the image set up for the older Pi yet, I'll try to find time to experiment a bit more this weekend.

Mike

14:18:54, 23rd September 2017   |   Permalink   |   View Source
thebeetleuk

I'm really struggling to create a working Pi setup. Mike, I dont suppose you can share your image somewhere? I's also running an older pi (Model B+).

07:57:01, 23rd September 2017   |   Permalink   |   View Source
sandy STAFF

Hi Mike,

Thanks for your detailed post!

Apologies for neglecting the Raspberry Pi and ROS stuff 'til now. I've spent a little bit of time on it today, and I'll be doing a lot more with it over the next couple of weeks - including posts on how to get things like basic football and face detection running

Will also be putting out an update to the image quite soon, as there are a couple of issues with it.

I'll also need to update the getting started with a pi article as it does seem to miss out a few things.

That image is indeed designed for a Pi3, and makes use of the inbuilt WiFi to generate a hotspot using hostapd. We normally connect a Wifi dongle to it too, and use that to connect to local WiFi, to get the best of both worlds. However, I noticed that the learn article instructions do not actually tell you how to get the main WiFi to connect to WiFi rather than being a hotspot, so we'll need to fix that.

It would be good to know more about why Marty is not always being found. If you sudo marty-stop, then sudo marty-start, you'll be able to see the output as the Marty services start

Also please be cautious if powering the pi externally while it's connected to Marty. The cable we provide is designed to carry power from the control board's 5V regulator, so if you also plug in the Pi's micro-USB power, you'll have two regs feeding the same 5V line, which might cause trouble...

The last problem sounds a lot like battery/low voltage trouble. The additional drain of a pi does pull down the output voltage of the battery. We have low-voltage cutoff circuity to protect the battery from overdischarge, so if the voltage drops too low that'll kick in. There's not quite enough hysteresis on that cutoff, so it gets stuck cycling on/off. Because the motors give a little jerk on power-on, you get unintended movement. For the future, we're getting cells with higher discharge capability, which will stop the voltage dropping so much, and we'll be looking at the cutoff circuity itself.

In the mean time, you can make sure the battery is kept topped up - or upgrade it to one that's a little bit more chunky - such as this one which we often use

All the best,

Sandy

17:33:26, 17th September 2017   |   Permalink   |   View Source