What to do if Calibration or Scratch can't find your Marty

We're working on making the Marty scanning tools more robust, but while we're doing that there are other ways to get your Marty connected

If you've done the WiFi setup, and Marty is connected to your WiFi (so there's no "Marty Setup" network any more), then here's a video showing how you can find Marty's IP address directly, and use that in calibration tool or Scratch.

Finding Marty's IP

Quick overview

In case you don't like watching videos - here are the basics:

1) Download an IP scanning tool like - we recommend Angry IP Scanner

2) Click the preferences button preferences, and set the Display settings to show "Alive hosts (responding to pings) only"

ip scanner preferences

3) Click the "Fetchers" button fetchers (next to the Start button) and add the "MAC Vendors" field to the list on the left, by clicking it on the right hand list and clicking the arrow that points left

ip scanner fetchers

4) Click the Start button, and wait for the scan to finish. You'll get a list a bit like this

IP Scanner list

5) Look for an entry with the MAC Vendor "Espressif" - that will most likely be a Marty! The number in the IP column of that row is Martys IP. In this case it's 192.168.0.33

6A) In Scratch, if the scanner doesn't find a Marty, a "Select Marty on IP:" block will appear at the bottom. Put the IP address you just found in there and double click it to select Marty

Scratch add Marty by IP

6B) In the Calibration tool, if the scanner doesn't find a Marty, it'll give you the option to add by IP. Enter the IP address you just found and click the add button

Calibration add Marty by IP

Hopefully that helps. We're working on making the scanner detect Marty automatically more reliably, but in the mean time you should still be able to use your Marty!

Sandy

Discussion

Leave a comment and join the discussion here


Please Log In or Sign Up to write a comment response

8 Responses

sandy OP STAFF

Hello williammccarthy!

Sounds like your computer has connected ok to the Marty Setup network, and the next step is to set up the WiFi to get Marty on to your normal WiFi network. There are some instructions here: https://robotical.io/learn/article/14/Get%20Started%20with%20Marty/Get%20up%20and%20Running/ And you can either use a phone app or the web based setup

The reason the yellow triangle has appeared is because when you're connected to the Marty Setup network, you're connected to Marty directly, and not to the wider internet. That's perfectly fine for setting up the WiFi on Marty, and after everything is configured Marty will be on your usual wifi network

Hope that makes sense, let me know how you get on

Sandy

11:56:15, 07th August 2018  *   |   Permalink   |   View Source
williammccarthy

Hello World! I am trying to set up my brand new Marty using my Windows 10 laptop. My PC has detected Marty and I have a set of numbers listed below: Marty set up: 8366794 IPV4 address 192.168.4.2 IPV4 DNS servers 192.168.4.1 Now comes the problem: When Marty and my PC are trying to connect my PC is losing the wifi connection. I have a yellow triangle in the lower tray and a pop up Aw Snap no internet conncetion ………………… Any thoughts or suggestions please? Regards William

06:22:07, 07th August 2018   |   Permalink   |   View Source
23parislau

My only other option is to get a router with a 4g usb dongle (ie. replace the hot spot).

Update: I found a solution which works. 1) On Marty determine what is his/her IP address (e.g. 192.168.1.43)

2) on your laptop (e.g. I use Chrome to calibrate Marty). 3) go to Windows Control panel and change the IP GATEWAY address to by 192.168.1.43 (i.e. the same as MARTY). Save and if need be restart the laptop 4) turn on MARTY and go to the laptop/Chrome and SCAN 5) Marty should be found and you can level his/her eyes 6) SAVE config and WALK this did it for me. Now I can use the SCRATCH examples and ask my daughter to show case MARTY & SCRATCH programming at her Science Show (STEM) ... tomorrow !!! :-)

01:23:59, 29th April 2018   |   Permalink   |   View Source
23parislau

Hi Windy54 I have exactly the same issues. I setup a WiFi hotspot (note: the Android App does not accept a NULL password!). I have a spare laptop which has connected to the hot spot but and so too Marty but the scanner under chrome cannot 'see' Marty. I cannot even ping Marty on 192.168.43.18

01:15:20, 29th April 2018   |   Permalink   |   View Source
sandy OP STAFF

Hey,

Looks like I made a typo in the link to the Python file - sorry about that! It's online at https://cdn.robotical.io/misc/service_discovery.py

If you were entering the IP in Scratch and it still was having trouble connecting, it might be a timeout issue. I will have a look at extending the timeouts in the scanner

Hope you find your SD card!

Sandy

22:30:07, 25th October 2017   |   Permalink   |   View Source
Windy54

Hi, tried it again tonight down the hackspace. 10.14.225.99:81 gave the message "This is a websocket server only"

had several attempts with scratch trying to scan for Marty and entering the IP address and eventually it found Marty and connected. So I have demonstrated Marty to one Hackspace member who was in tonight.

Calibrate marty found it straight away. went to try the service_discovery.pi but the link came back with an error, file not found? ( sorry cant remember exactly what it was ) Had a quick look on github but could not see the file.

I was then going to try out the raspberry PI image, but somewhere between home and the hackspace I have lost my 16Gb SD card, so I am off home to find it!

20:07:11, 25th October 2017   |   Permalink   |   View Source
sandy OP STAFF

Hi Windy54,

Sorry to hear the WiFi was being so difficult. What we often do for demos and schools is actually to take around a Raspberry Pi set to operate in hotspot mode, that runs Scratch and provides the remote control etc. That is the most robust way to demo Marty as it then doesn't rely on any external internet connection. Our standard Raspberry Pi image is configured to do this, and there are some instructions for using it online here

However, it should not be so difficult to get Marty working on other WiFi. Especially when you entered the IP directly. Sometimes browsers have issues with caching which can cause problems - if you could replicate the situation and try going to martyIP:81 I'd be curious to know what happens. You should see a message saying it is a websocket server

We're working on getting the app out as soon as we can, which should be able to scan for Martys in a different way.

If you have Python, it would also be very helpful if you could try running this file: service_discovery.py to see if it can find your Martys. That uses a UDP multicast rather than simple IP scanning

Thanks for your patience - I really hope we'll be able to get this to be more reliable soon

All the best,

Sandy

11:31:03, 24th October 2017  *   |   Permalink   |   View Source
Windy54

so I have done all of the above and Marty still was not found.

I can connect to Marty at home via my virgin media wifi but nowhere else. Which is a real shame, on saturday I took Marty to creat-a-con in Leicester, a STEM event for 7-16 year olds. After spending a couple of hours on and off all day I could not connect to Marty. This was a shame because several parents came to my stand, said they had heard of it and were considering buying one. The fact mine was not working might have put them off.

SO tonight I took it to the hackspace and together with anther member spent 3 hours and could not get it to connect.

I had this theory that it is because at home my network is on 192..., all others we have tried are 10.10..., we proved this was incorrect by using an old SKY router and managed to connect to it on 10.10.1.68.

We found that Marty broadcasts a host name of ESP_F08CE0, the last 6 digits of my mac address. I could ping it using ping ESP_F08CE0 or ping 10.10.1.68. The SKY router was not connected to the internet so we could not use scratch.

We used my colleagues mobile phone to share the internet connection. Marty connected to his phone, we could ping Marty from my laptop. The calibration tool did not find it either by scanning or entering the IP address.

The hackspace has two wifi networks, we could not get Marty to work on either of them.

Any ideas as to what to try next? This is the second time I have tried to demonstrate Marty to hackspace members and failed. One of my reasons for purchasing Marty was to take it into schools , until the wifi issues are sorted this is going to be impossible.

22:12:48, 23rd October 2017   |   Permalink   |   View Source