Problems since pressing "bob the button"

So, built Marty, connected to my home wifi network and had some fun controlling Marty using scratch.

Now, I want to take it out and demonstrate it so I pressed bob the button to start the sequence again and connect to my phone as a mobile hot spot.

Nothing has worked since.

I connected Marty to my phone along with my laptop and confirmed both were connected. Then loaded scratchx but Marty was not detected.

So I pressed bob the button again and connected to my home network, went through the calibration procedure , scratchx still would not connect to Marty.

With Marty connected to my home network I logged into my router to get the IP address, when I click on device connection status nothing is displayed, an error message that the connection was dropped.

With Marty switched off, the router always displays the connected devices.

First time round I did not have to disable any ad blockers.

So at the moment I am very confused.

Steve

Discussion

Leave a comment and join the discussion here


Please Log In or Sign Up to write a comment response

4 Responses

sandy STAFF

Hi Steve,

Sorry it's still misbehaving!

You don't need to do the calibration more than once, but it can be useful for checking if Marty can be found on the network, since it scans in the same way as the Scratch interface does.

We do also have a more general scanning tool at http://docs.robotical.io/hardware/esp-socket-discovery/, although ideally you'd never have to use that!

It might be that we need to tweak the scanning tool a bit to increase the timeouts and make things a bit more robust. I'll get on that ASAP

Sandy

18:35:57, 22nd August 2017   |   Permalink   |   View Source
Windy54 OP

Hi Sandy, I should not have put video, checkout the following link https://robotical.io/learn/article/Get%20Started%20with%20Scratch/Introduction/ It is the get started with scratch article when you,press the Marty Scratch x button.

If you go through docs, standard setup with scratch and click the link it works.

I took Marty down the Hackspace tonight to show members and had problems with the wifi again. At home I had it working through my phone as a hotspot, I.e. Could control Marty through scratch x . Did not work at the Hackspace, I am guessing because I had none or a very poor 4g signal. So I tried to connect to the hackspace wifi, first time "bob the button" let me connect to the Marty hotspot and select the hackspace wifi. When I tried scanning for Marty it was not detected . Because it was not detected I did not try scratch x, from your reply though I should have gone straight to scratch.

I tried "bob the button" several times and cycled power but the hotspot was not created. At home with Marty on charge I have managed to connect to my home wifi.

I will try again on my phone tomorrow.

Steve

21:40:02, 21st August 2017   |   Permalink   |   View Source
sandy STAFF

Hello!

Sorry to hear about the trouble. One thing I've found is that sometimes after pressing Bob the Button to reset the Wifi, I do sometimes need to put the network info in twice for it to save. That bug is on the list to be looked into shortly!

Also - you should only need to do the calibration once, and not each time you configure the WiFi ;-)

I'm hoping that the reason Scratch couldn't find Marty was that it was a link to an old draft interface. When you say you clicked the link on the video - can you tell me which video it was and what the link was to?

Sandy

21:00:43, 21st August 2017   |   Permalink   |   View Source
Windy54 OP

right, well I am working again on my home network, have not got the energy to try and connect to my phone again. This may be my issues 1) I had the calibration tool open when I trie to open scratch. 2) I tried to open scratch x from the video by clicking on Marty Scratchx, scratch loaded but no extensions 3) If I click on docs, scratch then click to open scratch marty it works

tomorrow I will try the sequence again.

PS, it is a shame "bob the button" is not more accessible or a way of resetting the wifi network through software. These are my only "criticisms" of the robot. My grand children were very impressed when they saw him yesterday, I have got to get him to talk by next weekend !

18:29:50, 20th August 2017   |   Permalink   |   View Source